Please connect a razer synapse 2.0 enabled device mac

So I give them my details, create an account and eventually sign in to synapse. I was greeted with "For the full experience, please connect a razer synapse enabled device. So this is when I get a little annoyed and start some troubleshooting: - Unplugged it and put it all back in different USB slots. I've tried a few things I haven't mentioned but these were the main things. I will be sending an email to razer support but they have made something that should be simple, way more difficult than it should be and why?

It's like microsoft and what they tried to do with the xbox, you can't use it unless you're on the internet and signed in to live. I just want to be able to use all the buttons on the mouse and the mouse wheel, but I can't because razer has made it impossible to install the drivers without their POS bloatware. Apologies for the wall of text, I'm actually pretty pissed off this has been so difficult. In case anyone else comes across this post experiencing the same issue, please excuse my venting in the original post, I was very frustrated.

The solution however was to update my mother boards USB drivers from the manufacturers website. Just performed the troubleshooting I found here which did nothing. I also emailed them via their support page max characters so couldn't even describe all the troubleshooting I performed so hopefully they will be able to help me. Oct 17, 21 0 4, 1. Tearranverse Commendable.

Dec 3, 1 0 1, 0. Hey man have you found a solution to the problem? If so could you tell me how to fix it. I'm having the same problem. Kossen Commendable.

Feb 8, 1 0 1, 0. John Prominent. Apr 15, 5 0 0. Once your pc is booted back up,plug in your razer device s and go into razer synapse and it should've worked If it hasn't I have no clue of what to do. Apr 24, 2 0 0. John :. Jul 7, 1 0 0.

Jan 3, 1 0 0. So I found a fix to this after searching the internet for days. If you go to Device Manager and select update driver under keyboards and then pick a driver select the driver from Nothing else worked for me other than this and I tried everything!!!!! STEM Apps. Jun 6, 1 0 10 0. I've had continuous problems for the last 10 months on two different Lenovo laptops with Razer devices. Here's a list of symptoms: Devices disconnect and reconnect often. Devices don't respond to profile changes Pop up showing profile change for device stops working Device manager shows a huge list of unused items in "Human Interface Devices", "Keyboards" and "Mice and other Removing all software using a software removal program like Revo and then removing hidden devices for Razer devices, then reinstalling has some success but eventually the connecting and disconnecting comes back and the hidden devices mount up again.

This constant device contention is very annoying and it's hard to believe that even after releasing Synapse 3 they still don't have the right. Jun 22, 1 0 10 0. Jul 4, 1 0 10 0. You must log in or register to reply here. Post thread. News comments. PC Gaming. Graphics Cards. Started by boriss Yesterday at AM Replies: Resetting SMC worked! But it did work at the end just needed to wait. Both my MBP ports seemed to work — they recognised stuff and I could use them. Only then found this and Hey Presto!


  1. shes all i need mac demarco.
  2. Razer Synapse 2.0 offline saved settings and login, for offline PC's!
  3. mac os x delete caches folder.
  4. Customer Review Snapshot.
  5. About This Item.
  6. Razer Synapse 2.0 on macOS High Sierra issue;
  7. Register Now.

Thanks, this was helpful. Two things that might be worth paying attention to in addition though: — the USB connections will most probably not work while the Mac is charging its own battery. Hey guys, sometimes it happens cause of one pin of the USB port may be bent by pressure of usb device connector!

Incredible Connection

Check your port by looking at the port with a flash light. You can simply fix it. Push the bent pin by tip of a small screwdriver. Good Luck.

About This Item

Thanks a bunch! I get that a SMC reset should heal this. Im really frustrated, could this be a logic board issue? Anyone else have this issue? Late MacBook Pro 5,1. Still only one of them working on my early MacBook Pro. I tried the PRAM reset, too. Worked like on a charm on my Macbook Pro! My USB ports had stopped working. Took just a few minutes and I am back in business.

Brilliant thank you. I thought it was broken and bought a cheap new one which wrecked everything.

Approval required Mac synapse : razer

What sort of Apple-paid hack are you? Admit it. Actually USB usually does work. Usually means under normal conditions. So, under normal conditions, USB would work fine. But under abnormal conditions, USB may not work or stop working on a Mac, or any other computer. None of these resets worked. Any ideas? Worked on my Mac Pro Then when releasing buttons, it changed to green briefly then back to orange because it was not fully charged. Thought I did it wrong first time so repeated the process; same observation. My mouse is a cheap Logitech. And I was sure the USB port was not working by testing w the printer input cable between my two ports.

This worked like a charm guys!

Thanks guys! Took a couple of restarts before I got it right but it worked.

Im having problem with my macbook pro 13 inch early The problem im facing is that both of my usb port gives out power, for e. Is that overprice and should i attempt on repairing it myself by getting the the replacement of the ports on ebay or amazon? Thanks Alot Mac, Tested continity of the filters and they came back OK but obviously the resisitance had changed. Also There was 5v going to the USB and the data lines went from 0. This worked for me as well — yeesh I wish I had looked this up sooner, been living with only one port for a while now.

Same thing for my card reader if I use that instead of connecting the camera. I have a problem regarding with my mouse Razer Krait edition. I have already installed razer synapse in order for this thing to function properly but still it will not suddenly work few minutes after i plugged the device in the right usb port of my macbook. I tried to switch it on the other side but still the problem is the same. How can i manage this problem? Will you please guide me? Is there any reason as to why that would be? Is it possible it still reset? Thank you!